Symptom:
Program nemá spojení s internetem
Není funkční aktualizace programu
Není funkční aktualizace kurzovního lístku
Není funkční načtení partnerů pomocí IČ nebo komunikace se servery státní správy
Není funkční EET
Příčina:
Společnost Microsoft v této verzi Windows 10 ukončila podporu protokolu pro sdílení souborů SMB v.1 resp. verzí 1.0, 1.1, 2.0. Pokud se spouští jakákoli síťová aplikace, která dále sama komunikuje s internetem, tato komunikace je na úrovni operačního systému blokována, pokud je sdílená aplikace spouštěna ze serveru s protokolem pro sdílení souborů SMB 2.0 nebo nižším. Toto omezení se týká veškerých aplikací, které se spouští přes lokální síť.
Pro práci s IS PREMIER ve standardní verzi na síti, doporučujeme vrátit stav do předchozí verze Windows 10. Jak na to je popsáno ZDE
Řešení:
Doporučujeme vrátit předchozí stav Windows 10, viz. kapitola Vrátit předchozí verzi Windows 10
V případě Enterprise verzí programu je možné upravit nastavení serveru, jak je popsáno níže.
Na serveru, kde je IS PREMIER sdílen pro místní síť, je nutné aktivovat SMB v2.1. Tento protokol podporují jen operační systémy
Aktivace SMB je možné např. úpravou v registrech
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters] "SMB2"=- "SMB1"=-
Popřípadě přidejte na server přiložený REG soubor
Změnu v registrech je nutné provést jak na serveru, tak na PC s Windows 10 (1803) a po aplikování je nutný restart serveru i PC.
Ověřit, jakou verzi používá server je možné např. v PowerShell na stanici. Verze musí být 2.1 nebo vyšší